diff mbox

[pacman-dev] configure: bump libarchive requirements

Message ID 20180209021158.32681-1-i@jhuang.me
State Accepted, archived
Headers show

Commit Message

Huáng Jùnliàng Feb. 9, 2018, 2:11 a.m. UTC
bump libarchive requirement to >= 3.0.0 as we use `archive_write_free` available from 3.0.0

Signed-off-by: Huáng Jùnliàng <i@jhuang.me>
---
 configure.ac | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Allan McRae March 14, 2018, 2:28 a.m. UTC | #1
On 09/02/18 12:11, Huáng Jùnliàng wrote:
> bump libarchive requirement to >= 3.0.0 as we use `archive_write_free` available from 3.0.0
> 
> Signed-off-by: Huáng Jùnliàng <i@jhuang.me>

Applied.

Thanks,
A
diff mbox

Patch

diff --git a/configure.ac b/configure.ac
index 86f5bb6e..e382c50a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -216,8 +216,8 @@  AC_CHECK_LIB([m], [fabs], ,
 	AC_MSG_ERROR([libm is needed to compile pacman!]))
 
 # Check for libarchive
-PKG_CHECK_MODULES(LIBARCHIVE, [libarchive >= 2.8.0], ,
-	AC_MSG_ERROR([*** libarchive >= 2.8.0 is needed to compile pacman!]))
+PKG_CHECK_MODULES(LIBARCHIVE, [libarchive >= 3.0.0], ,
+	AC_MSG_ERROR([*** libarchive >= 3.0.0 is needed to compile pacman!]))
 
 # Check for OpenSSL
 have_openssl=no