[pacman-dev,1/1] autoconf: bump AC_PREREQ to 2.64

Message ID 20180208072529.12433-2-i@jhuang.me
State Accepted, archived
Headers show
Series bump AC_PREREQ to 2.64 on configure.ac | expand

Commit Message

Huáng Jùnliàng Feb. 8, 2018, 7:25 a.m. UTC
The acinclude.m4 uses AS_VAR_APPEND macro. This marco is introduced in 2.64[1], hence we bump AC_PREREQ to 2.64 to avoid undefined marco on 2.63 autoconf.

[1] https://lists.gnu.org/archive/html/autoconf/2009-07/msg00079.html

Signed-off-by: Huáng Jùnliàng <i@jhuang.me>
---
 configure.ac | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Allan McRae March 14, 2018, 2:29 a.m. UTC | #1
On 08/02/18 17:25, Huáng Jùnliàng wrote:
> The acinclude.m4 uses AS_VAR_APPEND macro. This marco is introduced in 2.64[1], hence we bump AC_PREREQ to 2.64 to avoid undefined marco on 2.63 autoconf.
> 
> [1] https://lists.gnu.org/archive/html/autoconf/2009-07/msg00079.html
> 
> Signed-off-by: Huáng Jùnliàng <i@jhuang.me>
> ---

Thanks,
A

Patch

diff --git a/configure.ac b/configure.ac
index 86f5bb6e..f6d5f819 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,7 +1,7 @@ 
 #                                               -*- Autoconf -*-
 # Process this file with autoconf to produce a configure script.
 # Minimum version of autoconf required
-AC_PREREQ(2.62)
+AC_PREREQ(2.64)
 
 # UPDATING VERSION NUMBERS FOR RELEASES
 #