mbox series

[pacman-dev,00/23] Docs Docs Docs 2: electric boogaloo

Message ID 20201207221956.667322-1-morganamilo@archlinux.org
Headers show
Series Docs Docs Docs 2: electric boogaloo | expand

Message

morganamilo Dec. 7, 2020, 10:19 p.m. UTC
Here's a redo of my original docs patch and more.

This time it's split in to many commits so it's hopefully easier to
review/rebase.

Every function, struct and param is now documented.

Simply `man libalpm` to get the main page. Then `man libalpm-databases`
to see the database section and so on for each section.

Also while doing all this, I thought it would make sense to change some
function names:

I also think alpm_unlock() should be named alpm_db_unlock() and
alpm_sync_get_new_version() should be named alpm_pkg_get_new_version()

Then the functions could be moved into the db and packages groups
repectivley.

To be clear I have not actually changed any function names in this patch
set.

morganamilo (23):
  doc: remove stray doxygen comment
  doc: add doc header to alpm.h
  doc: document error
  doc: document handle
  doc: document signatures
  doc: document depends
  doc: document callbacks
  doc: document databases
  doc: document logging
  doc: document packages
  doc: document files and groups
  doc: document transactions
  doc: document misc
  doc: document alpm_list
  doc: document options
  doc: move alpm_api group to top of file
  doc: move top level items into groups
  doc: configure doxygen
  doc: update doxyfile
  doc: rename alpm_api group to alpm
  doc: add extra documentation to the man page
  doc: change group names to libalpm_*
  doc: remove old libalpm man file

 doc/Doxyfile.in         |   83 +-
 doc/libalpm.3.asciidoc  |   37 -
 doc/meson.build         |    1 -
 lib/libalpm/alpm.h      | 2429 +++++++++++++++++++++++++++------------
 lib/libalpm/alpm_list.c |  251 ----
 lib/libalpm/alpm_list.h |  293 ++++-
 lib/libalpm/trans.c     |    2 -
 7 files changed, 2048 insertions(+), 1048 deletions(-)
 delete mode 100644 doc/libalpm.3.asciidoc

Comments

Colin Woodbury Dec. 7, 2020, 10:59 p.m. UTC | #1
I enjoy writing docs, is there anywhere you'd like a hand? 

On Mon, 7 Dec 2020, at 14:19, morganamilo wrote:
> Here's a redo of my original docs patch and more.
> 
> This time it's split in to many commits so it's hopefully easier to
> review/rebase.
> 
> Every function, struct and param is now documented.
> 
> Simply `man libalpm` to get the main page. Then `man libalpm-databases`
> to see the database section and so on for each section.
> 
> Also while doing all this, I thought it would make sense to change some
> function names:
> 
> I also think alpm_unlock() should be named alpm_db_unlock() and
> alpm_sync_get_new_version() should be named alpm_pkg_get_new_version()
> 
> Then the functions could be moved into the db and packages groups
> repectivley.
> 
> To be clear I have not actually changed any function names in this patch
> set.
> 
> morganamilo (23):
>   doc: remove stray doxygen comment
>   doc: add doc header to alpm.h
>   doc: document error
>   doc: document handle
>   doc: document signatures
>   doc: document depends
>   doc: document callbacks
>   doc: document databases
>   doc: document logging
>   doc: document packages
>   doc: document files and groups
>   doc: document transactions
>   doc: document misc
>   doc: document alpm_list
>   doc: document options
>   doc: move alpm_api group to top of file
>   doc: move top level items into groups
>   doc: configure doxygen
>   doc: update doxyfile
>   doc: rename alpm_api group to alpm
>   doc: add extra documentation to the man page
>   doc: change group names to libalpm_*
>   doc: remove old libalpm man file
> 
> doc/Doxyfile.in         |   83 +-
> doc/libalpm.3.asciidoc  |   37 -
> doc/meson.build         |    1 -
> lib/libalpm/alpm.h      | 2429 +++++++++++++++++++++++++++------------
> lib/libalpm/alpm_list.c |  251 ----
> lib/libalpm/alpm_list.h |  293 ++++-
> lib/libalpm/trans.c     |    2 -
> 7 files changed, 2048 insertions(+), 1048 deletions(-)
> delete mode 100644 doc/libalpm.3.asciidoc
> 
> -- 
> 2.29.2
>
morganamilo Dec. 7, 2020, 11:24 p.m. UTC | #2
On 07/12/2020 22:59, Colin Woodbury wrote:
> I enjoy writing docs, is there anywhere you'd like a hand? 
> 
> On Mon, 7 Dec 2020, at 14:19, morganamilo wrote:
>> Here's a redo of my original docs patch and more.
>>
>> This time it's split in to many commits so it's hopefully easier to
>> review/rebase.
>>
>> Every function, struct and param is now documented.
>>
>> Simply `man libalpm` to get the main page. Then `man libalpm-databases`
>> to see the database section and so on for each section.
>>
>> Also while doing all this, I thought it would make sense to change some
>> function names:
>>
>> I also think alpm_unlock() should be named alpm_db_unlock() and
>> alpm_sync_get_new_version() should be named alpm_pkg_get_new_version()
>>
>> Then the functions could be moved into the db and packages groups
>> repectivley.
>>
>> To be clear I have not actually changed any function names in this patch
>> set.
>>
>> morganamilo (23):
>>   doc: remove stray doxygen comment
>>   doc: add doc header to alpm.h
>>   doc: document error
>>   doc: document handle
>>   doc: document signatures
>>   doc: document depends
>>   doc: document callbacks
>>   doc: document databases
>>   doc: document logging
>>   doc: document packages
>>   doc: document files and groups
>>   doc: document transactions
>>   doc: document misc
>>   doc: document alpm_list
>>   doc: document options
>>   doc: move alpm_api group to top of file
>>   doc: move top level items into groups
>>   doc: configure doxygen
>>   doc: update doxyfile
>>   doc: rename alpm_api group to alpm
>>   doc: add extra documentation to the man page
>>   doc: change group names to libalpm_*
>>   doc: remove old libalpm man file
>>
>> doc/Doxyfile.in         |   83 +-
>> doc/libalpm.3.asciidoc  |   37 -
>> doc/meson.build         |    1 -
>> lib/libalpm/alpm.h      | 2429 +++++++++++++++++++++++++++------------
>> lib/libalpm/alpm_list.c |  251 ----
>> lib/libalpm/alpm_list.h |  293 ++++-
>> lib/libalpm/trans.c     |    2 -
>> 7 files changed, 2048 insertions(+), 1048 deletions(-)
>> delete mode 100644 doc/libalpm.3.asciidoc
>>
>> -- 
>> 2.29.2
>>

You're a little late now ;)

I guess go review it for me :P