[3/4] test/Makefile: Run tests with prove when available

Message ID 20200229000204.GA1596640@tsubame.mg0.fr
State New
Headers show
Series [1/4] TESTING: Step for installing the Python package | expand

Commit Message

Frédéric Mangano-Tarumi Feb. 29, 2020, 12:02 a.m. UTC
---
 test/Makefile | 7 +++++++
 1 file changed, 7 insertions(+)

Comments

Lukas Fleischer Feb. 29, 2020, 1:59 p.m. UTC | #1
On Sat, 29 Feb 2020 at 01:02:04, Frédéric Mangano-Tarumi wrote:
> ---
>  test/Makefile | 7 +++++++
>  1 file changed, 7 insertions(+)

Merged, thanks!

Patch

diff --git a/test/Makefile b/test/Makefile
index d310c8f5..758befa3 100644
--- a/test/Makefile
+++ b/test/Makefile
@@ -1,6 +1,13 @@ 
 T = $(sort $(wildcard *.t))
 
+PROVE := $(shell command -v prove 2> /dev/null)
+
+ifdef PROVE
+check:
+	prove .
+else
 check: $(T)
+endif
 
 clean:
 	$(RM) -r test-results/