[2/2] Add git-interface documentation to the web interface.

Message ID 20171113144914.8217-2-eschwartz@archlinux.org
State New
Headers show
Series [1/2] doc/git-interface: Fix configuration strings mangled by asciidoc | expand

Commit Message

Eli Schwartz Nov. 13, 2017, 2:49 p.m. UTC
Signed-off-by: Eli Schwartz <eschwartz@archlinux.org>
---
 doc/Makefile               | 2 +-
 web/html/git-interface.php | 3 +++
 web/lib/routing.inc.php    | 1 +
 3 files changed, 5 insertions(+), 1 deletion(-)
 create mode 100644 web/html/git-interface.php

Patch

diff --git a/doc/Makefile b/doc/Makefile
index df54c5d..d8617c4 100644
--- a/doc/Makefile
+++ b/doc/Makefile
@@ -1,4 +1,4 @@ 
-all: rpc.html
+all: rpc.html git-interface.html
 
 clean:
 	rm -rf *.html
diff --git a/web/html/git-interface.php b/web/html/git-interface.php
new file mode 100644
index 0000000..d4bfef2
--- /dev/null
+++ b/web/html/git-interface.php
@@ -0,0 +1,3 @@ 
+<?php
+echo file_get_contents('../../doc/git-interface.html');
+?>
diff --git a/web/lib/routing.inc.php b/web/lib/routing.inc.php
index 7d9750a..b5466d8 100644
--- a/web/lib/routing.inc.php
+++ b/web/lib/routing.inc.php
@@ -14,6 +14,7 @@  $ROUTES = array(
 	'/login' => 'login.php',
 	'/logout' => 'logout.php',
 	'/passreset' => 'passreset.php',
+	'/git-interface' => 'git-interface.php',
 	'/rpc' => 'rpc.php',
 	'/rss' => 'rss.php',
 	'/tos' => 'tos.php',