[3/3] Add basic Travis CI support

Message ID 20170825051053.20074-3-lfleischer@archlinux.org
State Accepted, archived
Headers show
Series [1/3] Do not hardcode path to the Python interpreter | expand

Commit Message

Lukas Fleischer Aug. 25, 2017, 5:10 a.m. UTC
Add a Travis CI configuration file to setup a test environment with all
the required dependencies and run the test suite.

Signed-off-by: Lukas Fleischer <lfleischer@archlinux.org>
---
 .travis.yml | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)
 create mode 100644 .travis.yml

Patch

diff --git a/.travis.yml b/.travis.yml
new file mode 100644
index 0000000..5bbfda1
--- /dev/null
+++ b/.travis.yml
@@ -0,0 +1,23 @@ 
+language: python
+
+python: 3.6
+
+addons:
+    apt:
+        packages:
+        - bsdtar
+        - libarchive-dev
+        - libgpgme11-dev
+        - libprotobuf-dev
+
+install:
+    - curl https://codeload.github.com/libgit2/libgit2/tar.gz/v0.26.0 | tar -xz
+    - curl https://sources.archlinux.org/other/pacman/pacman-5.0.2.tar.gz | tar -xz
+    - curl https://git.archlinux.org/pyalpm.git/snapshot/pyalpm-0.8.1.tar.gz | tar -xz
+    - ( cd libgit2-0.26.0 && cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr && make && sudo make install )
+    - ( cd pacman-5.0.2 && ./configure --prefix=/usr && make && sudo make install )
+    - ( cd pyalpm-0.8.1 && python setup.py build && python setup.py install )
+    - pip install mysql-connector-python-rf pygit2==0.26 srcinfo
+    - pip install bleach Markdown
+
+script: make -C test